]> the.earth.li Git - htag.git/blobdiff - debian/rules
Change to debhelper compat level 10
[htag.git] / debian / rules
index 6502ac038415d8568809bc6695bb2198bb6def7e..f255ea105ee76e40126ee1c422969ec1502917ad 100755 (executable)
@@ -1,8 +1,5 @@
 #!/usr/bin/make -f
 
-# Use debhelper v2.
-export DH_COMPAT := 2
-
 # Make sure perl is defined, but allow overriding from the command line.
 PERL ?= /usr/bin/perl
 
@@ -13,17 +10,19 @@ build:
 
 binary: binary-indep
 
+binary-arch: build
+
 binary-indep: binary-indep-stamp
 binary-indep-stamp: install
        dh_testdir
        dh_testroot
-       dh_installdocs docs/AUTHORS docs/BUGS docs/INSTALL \
+       dh_installdocs docs/AUTHORS docs/BUGS \
                docs/MACRO_DESCRIPTION docs/README \
-               docs/README.Multiple_Configs docs/TODO docs/TROUBLESHOOTING \
-               docs/URL docs/WRITING_SIGS
-       dh_installchangelogs docs/Changelog.htag docs/Changelog.htagplugin
+               docs/TODO docs/TROUBLESHOOTING \
+               docs/URL docs/Changelog.htagplugin
+       dh_installchangelogs docs/Changelog.htag
        dh_installexamples docs/sample-config/*
-       dh_installmanpages
+       dh_installman htag.1
        dh_fixperms
        dh_installdeb
        dh_perl