]> the.earth.li Git - onak.git/blobdiff - debian/rules
Fix up Debian systemd control file to allow non-socket activation
[onak.git] / debian / rules
index 4c1e6ddde8697c297d35f676b7b4a045a116a568..ad82309025191867d7107b861d674ddb4ef6abb0 100755 (executable)
@@ -1,8 +1,15 @@
 #!/usr/bin/make -f
 
-DEB_CONFIGURE_EXTRA_FLAGS += --enable-backend=dynamic
+DEB_CONFIGURE_EXTRA_FLAGS += --enable-backend=dynamic --runstatedir=/run
 
 CFLAGS += -std=gnu99
 
 %:
-       dh "$@" --with autoreconf
+       dh "$@" --with autoreconf,systemd
+
+override_dh_installinit:
+       dh_installinit --no-start
+
+override_dh_systemd_enable:
+       dh_systemd_enable --no-enable debian/onak.service
+       dh_systemd_enable --no-enable debian/onak.socket