]> the.earth.li Git - onak.git/blobdiff - debian/rules
Add all hardening options for Debian build (in particular for bindnow + pie)
[onak.git] / debian / rules
index 4c1e6ddde8697c297d35f676b7b4a045a116a568..13bdadca02f7254cca2ab1d9684f9dece99cfbf1 100755 (executable)
@@ -1,8 +1,16 @@
 #!/usr/bin/make -f
 
-DEB_CONFIGURE_EXTRA_FLAGS += --enable-backend=dynamic
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+DEB_CONFIGURE_EXTRA_FLAGS += --enable-backend=dynamic --runstatedir=/run
 
 CFLAGS += -std=gnu99
 
 %:
-       dh "$@" --with autoreconf
+       dh "$@" --with autoreconf,systemd
+
+override_dh_installinit:
+       dh_installinit --no-start
+
+override_dh_systemd_enable:
+       dh_systemd_enable --no-enable debian/onak.service
+       dh_systemd_enable --no-enable debian/onak.socket